«Обнаружена новая версия WordPress… пожалуйста обновитесь»

Многие вчера и позавчера видели такую фразу в админке и не раз задавали вопрос как от нее избавиться.

Решение простое:

Если у вас пишется после установки моей сборки 2.7, что ее все равно требуется обновить, то скачайте этот файл и распакуйте в wp-includes — там добавлена одна строка, указываящая локализацию вашей установленной версии.

Дистрибутив также обновил. Если вы скачали его после 13 декабря 03:00(МСК) то это вас не касается :-) Если до — то скачайте вышеприведенный файл и распакуйте куда указано.

Принцип действия «фишки» простой — если там прописано в этом файле ru_RU и в вашем конфиге тоже WPLANG равный ru_RU (а так у 99% пользователей русской версии), то автообновление будет работать из неправильного(читай «официального«) источника. Не пользуйтесь автообновлением вообще пока.

Если вы случайно воспользовались «автообновлением» и у вас заменился мой перевод на «официальный», то скачайте этот архив и распакуйте все файлы из него в /wp-content/languages/

Связанные записи