Русский WordPress 2.5 Lecactus Edition

WordPress 2.5 Russian

Мы наконец дождались выхода «финальной» версии 2.5. Не все ошибки еще исправлены, поэтому я не могу рекомендовать использовать новую версию для немедленного обновления предыдущей, по причине того что некоторые плагины могут отказаться работать, либо будут работать некорректно.
Если вы обновите ваш блог версии 2.3.* с уже активированными плагинами, то возможно часть из них, а может и все будут работать корректно.

Также у новой версии выросли системные требования: Php 4.3+, Mysql 4.0+ (рекомендуется 4.1+ для нормальной работы с utf-8) и самое главное рекомендуется минимум 32мб лимит памяти php

Думаю, что не нужно напоминать, что в любом случае прежде чем обновлять систему — сделайте бэкап базы данных и переименуйте старые каталоги wp-admin и wp-includes.
В эту сборку я включил только самые важные плагины это maxsite russian-date и rus-to-lat + одну темуОбновлено 23-04-2008: несколько тем оформления админки для желающих «поиграться» с интерфейсом (темы «leopard» и «fluency» не работают в IE).
Если вы хотите просто попробовать новую версию в работе на «чистом блоге», то ставить ее также легко как и предыдущие.
Я проверил обновление с 2.3.3 до 2.5 — все прошло гладко. Плагин автоматического обновления не тестировал, поэтому в сборку его не включал. Другие плагины, которые присутствовали в прошлых сборках также временно не включены, т.к. отсутствуют полноценно работающие версии.

Моя русская сборка включает перевод (файлы ru_RU.mo):

  • 2138 строк в файле локализации движка
  • 129 строк в файле локализации темы kubrick

а также переведенные внутри кода файлы:

  • readme.html
  • wp-blog-header.php
  • wp-settings.php
  • wp-config-sample.php
  • wp-db.php
  • setup-config.php
  • upgrade.php
  • install.php

Рекомендуется к прочтению всем желающим установить новую версию: что нового и как подготовиться к переходу
http://maxsite.org/wordpress-25-rc1
http://www.mikolka.info/2008/03/19/prishlo-vremya-25-wordpress-25-rc1/
http://www.cybercore.ru/wordpress-2-5-update/
http://blog.trampampam.ru/wordpress/wp25/
а также мою недавнюю запись о замеченных багах (исправляется этим патчем (в данном дистрибутиве патча нет, качайте отдельно если требуется)) в браузерах Opera и IE
Как вы наверное знаете, мой перевод, по сложившимся обстоятельствам не является «официальным», т.е. не размещаемым на сайте wordpress.org в русском разделе. Я его выкладываю для вас, уважаемые читатели, по той причине, что мне лично не нравится качество «официального» перевода.

Больше спорить насчет этого и вообще кто делает лучше я не собираюсь. Пусть пользователи wordpress сами выбирают :-)

Скачать (ссылку удалил 6 мая 2008г)

УДАЛЕНО!

Связанные записи

133 комментария на запись “Русский WordPress 2.5 Lecactus Edition”

  1. keetano 30 марта 2008 в 0:39

    если там обновления только по админке то не вижу смысла на него переходить :-)

  2. Lecactus 30 марта 2008 в 0:47

    если там обновления только по админке то не вижу смысла на него переходить :-)

    вообще то не только админка, но часть нововведений непонятно еще для чего сделана… весь потенциал еще не раскрыт. Кстати несмотря на точ товначале мне новый редактор не понравился, я запустил один сайт на новой версии и уже приспособился. Работает все очень быстро. вот советую почитать, если еще не успел (ссылки добавил в запись)

  3. Dipsy 30 марта 2008 в 0:48

    Очень и очень интересная версия!
    Кажется, это просто выше ожиданий, админка теперь как живая что ли, но все очень интуитивно, но на первый взгляд необычно. Тем более что я всегда любил все глючное и новое, когда можно и самому что-нибудь ковырнуть и исправить.

  4. Санек 30 марта 2008 в 1:35

    Не пойму как в вордпрессе считываются двоичные *.mo файлы локализаций, может кто подскажет как там происходит этот процесс?

  5. dimaka 30 марта 2008 в 2:46

    Не могу скачать :(

  6. SlaviO 30 марта 2008 в 3:56

    Не все ошибки еще исправлены, поэтому я не могу рекомендовать использовать новую версию для немедленного обновления предыдущей, по причине того что некоторые плагины могут отказаться работать, либо будут работать некорректно.

    Какие ошибки, это же финальная версия? И тогда когда же обновляться?

  7. SlaviO 30 марта 2008 в 4:00

    да и ещё:

    и самое главное рекомендуется минимум 32мб лимит памяти php

    Это имеется ввиду оперативки на сервере?! O_o У меня на мастерхосте сайт, там 8 тока ((((

  8. Ptath 30 марта 2008 в 4:21

    Не качается отсюда, скорее всего сервер перегружен =( Нельзя ли на какой-нить rapidshare выложить?

    Каждое обновление страницы количество скачиваний увеличивается на 5-10, зело популярный файл =)

  9. Nixon 30 марта 2008 в 4:45

    SlaviO

    У меня с тем же количеством памяти пока прекрасно работает версия 2.5, даже с плагинами которые стояли ранее) Есть ощущение, что стало даже чуть быстрее.

  10. mlmer 30 марта 2008 в 5:12

    Обновляться пока страшновато, а вот в качестве эксперимента на отдельный хост уже конечно поставил. Общие впечатления — положительные. Я wordpress`ом пользуюсь всего месяца четыре, так что прикипеть к старой админке не успел: новая нравится больше, но, похоже, это вопрос привычки.

    Спасибо вам за перевод. Предпочитаю ваши варианты тому, что лежит на оф. сайте. Правда, для 2.5 официальную версию уже и не смотрел :)

    Есть один вопрос по существу: как дела в новой версии с известными дырами, вроде XSS, которые в 2.3.x закрывались с помощью отдельных плагинов?

  11. webnet 30 марта 2008 в 5:47

    Сделал упдэйт . Все работает кроме одного плагина . Обидно ! =(

  12. Virtual 30 марта 2008 в 10:10

    Попробовал автоматическое обновление, вылазит сообщение, что не может обновить файлы.

  13. Virtual 30 марта 2008 в 10:13

    Сейчас попробовал автоматическое обновление — вылазит сообщение, что невозможно обновить файлы.

  14. Lecactus 30 марта 2008 в 10:27

    Какие ошибки, это же финальная версия? И тогда когда же обновляться?

    я имею ввиду что обычно более менее безглючные бывают версии вида 2.*.1 :-)

    Не качается отсюда, скорее всего сервер перегружен =( Нельзя ли на какой-нить rapidshare выложить?

    Каждое обновление страницы количество скачиваний увеличивается на 5-10, зело популярный файл =)

    качать запрещено если криво настроен браузер (не выдает реферер). временно отключил защиту. выкладывать на рапидшару не буду и не разрешаю. Когда выйдут несколько плагинов для более полной сборки и протестирую все, то выложу на Mywordpress.ru
    PS сервер у меня свой личный и перегружаться там нечему особо, тем более страницы ведь вам показываются :)

    Сейчас попробовал автоматическое обновление — вылазит сообщение, что невозможно обновить файлы.

    дайте права 777 на все папки тогда обновляться будет, потом вернете на место. Хотя если честно ничего страшного в обновлении с 2.3.* до 2.5 нет — можете и вручную все сделать

    Сделал упдэйт . Все работает кроме одного плагина . Обидно ! =(

    вас предупреждали что не все будет работать :)

    Обновляться пока страшновато, а вот в качестве эксперимента на отдельный хост уже конечно поставил. Общие впечатления — положительные. Я wordpress`ом пользуюсь всего месяца четыре, так что прикипеть к старой админке не успел: новая нравится больше, но, похоже, это вопрос привычки.

    Спасибо вам за перевод. Предпочитаю ваши варианты тому, что лежит на оф. сайте. Правда, для 2.5 официальную версию уже и не смотрел :)

    Есть один вопрос по существу: как дела в новой версии с известными дырами, вроде XSS, которые в 2.3.x закрывались с помощью отдельных плагинов?

    плагин писали MAX и Ю.Б. поэтому по работе этого плагина уточните у них, я его не включал пока в архив.

  15. Lecactus 30 марта 2008 в 10:41

    Не пойму как в вордпрессе считываются двоичные *.mo файлы локализаций, может кто подскажет как там происходит этот процесс?

    в поиск: http://wordpress.org/search/gettext

  16. keetano 30 марта 2008 в 11:55

    я кстати вдруг понял что ничего мне не мешает установить 2.5 локально и уже там глянуть стоит переходить или нет :-)

  17. ontolog 30 марта 2008 в 12:27

    Я у себя обновил WordPress до версии 2.5. Свои проблемы с установкой описал здесь.
    Вкратце — Не запустились плагины Popularity Contest, Digital Fingerprint, LiveJournal Crossposter, MaxSite Sape. В целом движок работает побыстрее чем 2.3. Хотя у меня это может быть связано с неактивацией 10 плагинов.

  18. Моня 30 марта 2008 в 12:46

    Не получилось установить :(
    Базу данных создал, wp-config.php отредактировал, пишет:

    ———————————————————-
    Готово!

    WordPress установлен. Ожидали больше шагов? Это все!
    Имя пользователя admin
    Пароль ********

    Запомните этот пароль! Он абсолютно случаен и создан специально для вас.

    Войти
    ———————————————————-

    Нажимаю «Войти» и он выдает мне:

    ———————————————————-
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, *****@mail.ru and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    Apache/2.2.4 (Win32) PHP/5.2.3 Server at localhost Port 80

  19. Lecactus 30 марта 2008 в 13:08

    Не получилось установить :(
    Базу данных создал, wp-config.php отредактировал, пишет:

    Нажимаю «Войти» и он выдает мне:

    ———————————————————-
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, *****@mail.ru and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    Apache/2.2.4 (Win32) PHP/5.2.3 Server at localhost Port 80

    попробуй удалить htaccess из корня если есть и вообще — обратись к хостеру как указано. может что подскажет

  20. Моня 30 марта 2008 в 13:21

    Колдовство! Действительно помогло!

  21. mikolka 30 марта 2008 в 13:52

    Ох, и начнется сейчас.

  22. Dipsy 30 марта 2008 в 15:03

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, *****@mail.ru and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    Apache/2.2.4 (Win32) PHP/5.2.3 Server at localhost Port 80

    У меня хостер любезно сам исправил ошибку в файле .htaccess

  23. Адфыр 30 марта 2008 в 15:04

    Решил не мусорить вчера, но раз такое дело…
    1. Лекактусу спасибо за оперативность.

    2. Не пашет tinyMCE в админке (( :
    ФайрБаг пишет:

    tinyMCE is not defined
    go(«content»)editor.js (line 73)
    onclick(click clientX=0, clientY=0)post-new.php (line 1)
    [Break on this error] var ed = tinyMCE.get(id);

    3. ГДЕ УСТАНОВКА ДАТЫ ДЛЯ ПОСТА (ВРУЧНУЮ) ?

    Пока всё.

  24. Alt-Shift 30 марта 2008 в 15:36

    Обновила движок. Вроде почти все работает. Не работает эта новая медиагалерея. При загрузке любого изображения сразу выдается ошибка, что файл не загружен. Тем не менее в списке он просматривается. Но сделать с ними ничего нельзя: ни вставить, ни посмотреть. Как от этого избавиться?

  25. traaance 30 марта 2008 в 17:44

    Спасибо за перевод.

  26. Lecactus 30 марта 2008 в 17:49

    tinyMCE is not defined
    go(«content»)editor.js (line 73)
    onclick(click clientX=0, clientY=0)post-new.php (line 1)
    [Break on this error] var ed = tinyMCE.get(id);

    3. ГДЕ УСТАНОВКА ДАТЫ ДЛЯ ПОСТА (ВРУЧНУЮ) ?

    Пока всё.

    у меня tinymce работает во всех браузерах :-) без ошибок
    установка даты там есть справа — там где кнопка «опубликовать» есть опция НЕМЕДЛЕННО и ссылка на редактирование даты

    Обновила движок. Вроде почти все работает. Не работает эта новая медиагалерея. При загрузке любого изображения сразу выдается ошибка, что файл не загружен. Тем не менее в списке он просматривается. Но сделать с ними ничего нельзя: ни вставить, ни посмотреть. Как от этого избавиться?

    про галерею почитайте по ссылкам выше в записи. я с ней вообще не разбирался. по поводу НИ ВСТАВИТЬ НИ ПРОСМОТРЕТЬ — опять же почитайте по ссылке на мою прошлую запись — ссылка есть выше. нормально все загружается и работает только в браузерах САФАРИ и ФАЙРФОКС

  27. SlaviO 30 марта 2008 в 19:41

    А можно по подробнее об авто обновлении? Тоесть выставить права 777, запустить в админке обновление, а потом залить русскую версию или как?

  28. Lecactus 30 марта 2008 в 20:03

    А можно по подробнее об авто обновлении? Тоесть выставить права 777, запустить в админке обновление, а потом залить русскую версию или как?

    проще обновить залив вручную. мне самому лично не нравится все «автоматическое». Если стоит английский плагин автообновления то он скачает новую версию с ВП.ОРГ и потом нужно будет просто заменить вручную модуль локализации. Если же стоит русская версия плагина то он пытается скачать с mywordpress а там я еще не выкладывал и ничего не получится.

  29. Silence 30 марта 2008 в 20:22

    вай, а чё кто-то с русской секции wordpress.org качает? я уже забыл что она есть даже.

    спасибо за локализацию ))

  30. traaance 30 марта 2008 в 20:50

    Нашел баг в переводе) Когда выхожу из админки, то: http://traaance.org/other/wp_ru_bug.jpg

  31. Lecactus 30 марта 2008 в 21:10

    Нашел баг в переводе) Когда выхожу из админки, то: http://traaance.org/other/wp_ru_bug.jpg

    исправил. свежий перевод доступен здесь http://lecactus.ru/wordpress/latest-russian-translation-for-wordpress/ просто замени файл ru_RU.mo

    PS в полном дистрибутиве тоже обновил

  32. insight 30 марта 2008 в 23:52

    Установил 2.5 Всё подцепилось, но при регистрации нового юзера wp-mail-cyrillic выдает вот это..

    Fatal error: Call to undefined function: htmlspecialchars_decode() in /usr/sites/bardo.fm/flow/wp-content/plugins/wp-mail-cyrillic/wp_mail_cyr.php on line 159

    Попробую отключить плагин, может без него теперь корректная кодировка..

  33. runarius 31 марта 2008 в 3:46

    Огромное спасибо за работу по локализации!!! Буду пробовать ставить!

  34. shperk 31 марта 2008 в 9:42

    Чё-то у меня не встал rustolat плагин.
    Выдает ошибку
    Fatal error: Cannot redeclare sanitize_title_with_translit() (previously declared in /home/тратата/www/wp-includes/languages/ru_RU/rus-to-lat.php:48) in /home/тратата/www/wp-content/plugins/rus-to-lat.php on line 59

    А у остальных — работает?
    Без rustolat нет смысла начинать работу — потом замучаешься вручную править…

  35. Жилинский 31 марта 2008 в 10:30

    Спасибо (в кошельке), работает :-)

  36. Lecactus 31 марта 2008 в 10:56

    Чё-то у меня не встал rustolat плагин.
    Выдает ошибку
    Fatal error: Cannot redeclare sanitize_title_with_translit() (previously declared in /home/тратата/www/wp-includes/languages/ru_RU/rus-to-lat.php:48) in /home/тратата/www/wp-content/plugins/rus-to-lat.php on line 59

    А у остальных — работает?
    Без rustolat нет смысла начинать работу — потом замучаешься вручную править…

    УДАЛИТЕ ФАЙЛ rus-to-lat.php из папки wp-includes/languages/ru_RU !
    грубо говоря он у вас два раза присутствует. поэтому и выдает такую ошибку подозреваю что в папке languages еще осталось от WP 2.2.x

  37. shperk 31 марта 2008 в 12:06

    И вправду присутствует. При чем при попытке удаления вызывает фатальную ошибку даже при деактивированном плагине.
    Мля, один раз поддался на уговоры хостера и поставил WP мастером с Мажордомо. Лень было копаться. Готов был к тому, что он поставит старую версию. Но что это будет 2.2.1 — не ожидал!
    Счас буду переставлять начисто, а то, чувствую, подобного д»»»ма еще много будет…
    Мораль — бойся данайцев, даже дары приносящих. Только то, что сделал своими ручками, будет работать.

  38. Denx 31 марта 2008 в 12:44

    Спасибо!

  39. Дмитрий 31 марта 2008 в 17:02

    Ну мое мнение стало по лучше, и правда по быстрее, пока правда только на денвере тестил. Нашел несколько косяков, например по загрузке картинок:
    1) Тыкаешь чтобы ссылка была на страницу, а не на файл, он делает ссылку вообще на страницу этого файла (т.е. там только эта картинка, и больше ничего).
    2) Тыкаешь оптекание по левому краю, один фиг втыкает просто, без оптеканий.

  40. Lecactus 31 марта 2008 в 17:13

    Ну мое мнение стало по лучше, и правда по быстрее, пока правда только на денвере тестил. Нашел несколько косяков, например по загрузке картинок:
    1) Тыкаешь чтобы ссылка была на страницу, а не на файл, он делает ссылку вообще на страницу этого файла (т.е. там только эта картинка, и больше ничего).
    2) Тыкаешь оптекание по левому краю, один фиг втыкает просто, без оптеканий.

    1 так и задумано. так было ВСЕГДА, посмотрите на прошлых версиях и убедитесь.
    2 в ФФ у меня должно все работать нормально. даже если в редакторе не видно выравнивания, то на странице при показе оно должно присутствовать

  41. Дмитрий 31 марта 2008 в 17:22

    1 так и задумано. так было ВСЕГДА, посмотрите на прошлых версиях и убедитесь.
    2 в ФФ у меня должно все работать нормально. даже если в редакторе не видно выравнивания, то на странице при показе оно должно присутствовать

    1. Да Вы что?! У меня всегда ссылка шла на страницу с сообщением, ну вот например тут посмотрите И так еще примерно на 10 сайтах.

  42. Марк 31 марта 2008 в 21:20

    На странице установки неверно сформулирована фраза про доступ поисковикам.

  43. Lecactus 31 марта 2008 в 23:15

    1. Да Вы что?! У меня всегда ссылка шла на страницу с сообщением, ну вот например тут посмотрите И так еще примерно на 10 сайтах.

    на стандартной теме посмотрите как работает.

    На странице установки неверно сформулирована фраза про доступ поисковикам.

    спасибо за внимательность. есть такое дело, вижу. исправил. просто в файле перевода была похожая фраза. кстати ошибка существует с версии 2.3, но никто больше не писал про это. полный дистрибутив и отдельный архив с русификатором обновил.

  44. mikolka 31 марта 2008 в 23:29

    Заглянул на офф. форум — мдя… что твориться…

  45. Lecactus 31 марта 2008 в 23:41

    Заглянул на офф. форум — мдя… что твориться…

    это ты про что конкретно? :-)

  46. Alexandr 1 апреля 2008 в 2:27

    Можно попросить исправить «Панель приборов», на «Панель управления», а то напрягает? Прям как в том анекдоте :)
    .
    — Петька, приборы!
    — 120, Василий Иванович!
    — Что «120»?!
    — А, что «приборы»?!

  47. Kuja 1 апреля 2008 в 4:08

    Мод админки WP — Fluency обновился.
    http://deanjrobinson.com/projects/fluency-admin/

  48. DanBlogger 1 апреля 2008 в 4:26

    Перешёл на 2.5 Теперь жалею. Полетели как всегда русские буквы.

    А этот сайт благорозумно не стал переходить на 2.5
    :)

  49. Lecactus 1 апреля 2008 в 8:50

    Перешёл на 2.5 Теперь жалею. Полетели как всегда русские буквы.

    А этот сайт благорозумно не стал переходить на 2.5
    :)

    То что у вас полетели русские буквы говорит только о том что у вас кодировка базы была кривая

  50. Lecactus 1 апреля 2008 в 8:51

    Можно попросить исправить «Панель приборов», на «Панель управления», а то напрягает? Прям как в том анекдоте :)
    .
    — Петька, приборы!
    — 120, Василий Иванович!
    — Что «120»?!
    — А, что «приборы»?!

    вы адресом сайта ошиблись. Панель приборов — это не в моем переводе, а в переводе «официального wp»

  51. Lecactus 1 апреля 2008 в 8:59

    Мод админки WP — Fluency обновился.
    http://deanjrobinson.com/projects/fluency-admin/

    спасибо за информацию. за всем не уследишь. дистрибутив обновил

  52. DanBlogger 1 апреля 2008 в 9:04

    Перешёл на 2.5 Теперь жалею. Полетели как всегда русские буквы.

    А этот сайт благорозумно не стал переходить на 2.5
    :)

    То что у вас полетели русские буквы говорит только о том что у вас кодировка базы была кривая

    А вот и не угодали. Моя база изначально была utf8. Это wordpress 2.5 не ест тему на русском языке. Все php скрипты русской темы уже полгода в utf8 формате. Вот они то и косеют. До 2.5 всё было нормально.

  53. Lecactus 1 апреля 2008 в 9:13

    А вот и не угодали. Моя база изначально была utf8. Это wordpress 2.5 не ест тему на русском языке. Все php скрипты русской темы уже полгода в utf8 формате. Вот они то и косеют. До 2.5 всё было нормально.

    если не база кривая, значит хостер кривой и не выдает нормальную кодировку. посмотрите что у вас указано про кодировки в htaccess и wp-config
    кстати «база в утф8» тоже бывает разная. если в таблицах закорючки вместо нормальных букв то нужно исправлять. какая версия мускула?
    я ставил при тестировании на два разных хостинга, включая свой сервер с различным серверным ПО и все было идеально :-). кстати понятие «не ест тему» что означает? у вас не показывает содержимое блога или содержимое темы? скриншот добавьте хотя бы чтобы не гадать на кофейной гуще (кнопка для добавления скриншота тут есть)

  54. DanBlogger 1 апреля 2008 в 10:53

    В таблицах базы всё нормально. Хостинг не изменился. Теоритически конечно возможно, что они у себя что-то поменяли.

    В wp-config сейчас английский, был русский. Результат тот же.
    //define (‘WPLANG’, ‘ru_RU’);
    define (‘WPLANG’, »);

    Что значит, какая версия мускула?
    Вот можно посмотреть живьём
    http://www.danblogger.com/category/%d0%b1%d0%b8%d0%b7%d0%bd%d0%b5%d1%81/
    Не показывает содержимое темы, показывает содержимое блога правильно.
    Часть русских слов в теме я уже поменял на английские.

    Вот htaccess. Может PHP5 не правильно работает с wordpress 2.5 ?
    ErrorDocument 404 /oops.php
    # Use PHP5 as default
    AddHandler application/x-httpd-php5 .php .php4 .php3 .phtml .xml .xsl

    RewriteEngine On
    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

  55. Lecactus 1 апреля 2008 в 11:15

    Вот можно посмотреть живьём
    http://www.danblogger.com/category/%d0%b1%d0%b8%d0%b7%d0%bd%d0%b5%d1%81/

    все теперь понятно:
    сохраните ВСЕ файлы темы в кодировке utf8
    «проблема» эта всплывала десятки раз на форумах кстати и от версии ВП не зависит (обычно бывает что раньше была кодировка темы 1251 непонятно по каким причинам)
    http://lecactus.ru/2007/06/19/465/

  56. bublik 1 апреля 2008 в 15:31

    Напрягает что simple tags не работает :(
    А так новый вордпресс меня радует!

  57. Lecactus 1 апреля 2008 в 15:36

    Напрягает что simple tags не работает :(
    А так новый вордпресс меня радует!

    ST 1.5 обещают сделать для нового ВП скоро. я сам жду когда обновятся все нужные плагины

  58. kiote 1 апреля 2008 в 15:43

    после добавления комментария к посту добавляется еще и такая «дополнительная информация»:

    Комментариев (2) Project-Id-Version: WordPress 2.5 Russian Lecactus Edition Report-Msgid-Bugs-To: POT-Creation-Date: 2008-03-29 23:18+0600 PO-Revision-Date: 2008-03-30 22:12+0600 Last-Translator: Kalinin Ivan Language-Team: Lecactus MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit X-Poedit-Language: Russian X-Poedit-Country: RUSSIAN FEDERATION X-Poedit-SourceCharset: utf-8 Plural-Forms: nplurals=3; plural=(n%10==1 && n%100!=11) ? 0 : ((n%10>=2 && n%10<=4 && (n%100=20)) ? 1 : 2); X-Poedit-KeywordsList: __;_e;__ngettext:1,2;_c;__ngettext_noop:1,2 X-Poedit-Basepath: . X-Poedit-SearchPath-0: X:\web\wordpress\main\wordpress-2.5\wordpress

    как лечить, не подскажете?

  59. Lecactus 1 апреля 2008 в 16:14

    как лечить, не подскажете?

    ПОИСК РУЛИТ:
    http://forum.maxsite.org/viewtopic.php?id=3476
    http://forum.maxsite.org/viewtopic.php?id=2445
    http://mywordpress.ru/support/viewtopic.php?id=2678
    http://mywordpress.ru/support/viewtopic.php?pid=11861

  60. Lecactus 1 апреля 2008 в 16:39

    Напрягает что simple tags не работает :(
    А так новый вордпресс меня радует!

    ST 1.5 обещают сделать для нового ВП скоро. я сам жду когда обновятся все нужные плагины

    оно уже вышло оказывается. вечерком обновлю перевод если требуется

  61. kiote 1 апреля 2008 в 18:34

    спасибо! баг с комментариями зафиксила, действительно, проблему в форумах уже обсудили.. так что извините %)

  62. DanBlogger 1 апреля 2008 в 20:33

    Вот можно посмотреть живьём
    http://www.danblogger.com/category/%d0%b1%d0%b8%d0%b7%d0%bd%d0%b5%d1%81/

    все теперь понятно:
    сохраните ВСЕ файлы темы в кодировке utf8
    «проблема» эта всплывала десятки раз на форумах кстати и от версии ВП не зависит (обычно бывает что раньше была кодировка темы 1251 непонятно по каким причинам)
    http://lecactus.ru/2007/06/19/465/

    Проверил несколько раз, ВСЕ файлы темы в кодировке utf8.
    Мой блог был всегда в кодировке utf8. Никогда не был в в кодировке 1251.
    Надо попробовать какую-нибуть русскую тему, проверенно работающую в wordpress 2.5 Наверно таких сейчас нет. Все темы для wordpress 2.5 только на английском языке. :cry:

  63. Lecactus 1 апреля 2008 в 20:38

    Надо попробовать какую-нибуть русскую тему, проверенно работающую в wordpress 2.5 Наверно таких сейчас нет. Все темы для wordpress 2.5 только на английском языке. :cry:

    повторяю еще раз — версия 2.5 и 2.3 вообще не должна влиять на кодировку темы, если не сохранены какие либо файлы темы в кодировке 1251. судя по тому что баг у вас виден в основном при просмотре архивов то надо копать в archive.php. если хотети можете сами открыть нормальным текстовым редактором файлы темы и посмотреть в какой кодировке они.

    PS русифицировать или исправить тему — дело 5-30минут. если не знаете как это делать почитайте десятки страниц форумов на эту тему

  64. Блог об отношениях 1 апреля 2008 в 20:50

    К чёрту 2.5)) ещё полгода на 2.3.3 сидеть можно )

  65. DanBlogger 1 апреля 2008 в 20:51

    Повторяю, у меня все файлы и сама база есть и всегда были в utf8.
    Согласен, что версия 2.5 и 2.3 вообще не должна влиять на кодировку темы.
    archive.php и всё остальное в utf8.

    Надо попробовать какую-нибуть русскую тему, проверенно работающую в wordpress 2.5
    Наверно таких сейчас нет. Все темы для wordpress 2.5 только на английском языке. :cry: :cry: :cry:

  66. Xtwo 2 апреля 2008 в 14:32

    Можно как то откатить с 2.5 на 2.3 ?

  67. Lecactus 2 апреля 2008 в 14:45

    Повторяю, у меня все файлы и сама база есть и всегда были в utf8.
    Согласен, что версия 2.5 и 2.3 вообще не должна влиять на кодировку темы.
    archive.php и всё остальное в utf8.

    Надо попробовать какую-нибуть русскую тему, проверенно работающую в wordpress 2.5
    Наверно таких сейчас нет. Все темы для wordpress 2.5 только на английском языке. :cry: :cry: :cry:

    давно бы мне прислали тему вашу в архиве на мыло чтобы развеять все сомнения

    Можно как то откатить с 2.5 на 2.3 ?

    экспорт записей и и импорт. а вообще вас предупреждали что делайте бэкап базы

  68. Xtwo 2 апреля 2008 в 15:34

    Можно как то откатить с 2.5 на 2.3 ?

    экспорт записей и и импорт. а вообще вас предупреждали что делайте бэкап базы

    проблема в том, что при этом в админке начинают глючить «Всплывающие окна» например для вставки ссылки — они пустые и не закрываются…

  69. Lecactus 2 апреля 2008 в 15:50

    проблема в том, что при этом в админке начинают глючить «Всплывающие окна» например для вставки ссылки — они пустые и не закрываются…

    вы удалили все файлы нового движка и залили все старые? или просто залили старый поверх нового?

  70. LiveStalker 2 апреля 2008 в 18:11

    Я выбираю твой перевод! Спасибо!

  71. Uzbek 4 апреля 2008 в 20:29

    А на этом сайте сейчас стоит уже 2.5?
    Просто я обновился, все ок, только плагин для печати выдает теперь вместо страницы для печати 404-ю стр.
    А тут, я смотрю, он работает как надо…

  72. Lecactus 4 апреля 2008 в 20:41

    А на этом сайте сейчас стоит уже 2.5?
    Просто я обновился, все ок, только плагин для печати выдает теперь вместо страницы для печати 404-ю стр.
    А тут, я смотрю, он работает как надо…

    нет здесь еще не стоит 2.5.
    про плагин — обновите его до версии 2.30бета2
    http://lesterchan.net/wordpress/downloads/

  73. Alexandr 5 апреля 2008 в 10:03

    вы адресом сайта ошиблись. Панель приборов — это не в моем переводе, а в переводе “официального wp”

    Интересно получается: я скачал WP сначала с «официального wp»? обновился, потом появилась Ваша; скачал ее и развернул поверх предыдущей. О Панели прибоов сообщил — ибо стало напрягать. Что же в результате произошло?
    Кстати, новая темя для админки не работает у меня почему-то. В плагинах применяется, но ничего не происходит. Ошибок тоже не выдает. Что может быть?

  74. Alexandr 5 апреля 2008 в 10:11

    вы адресом сайта ошиблись. Панель приборов — это не в моем переводе, а в переводе “официального wp”

    Интересно получается: я скачал WP с «официального wp«, обновился. Потом появилась Ваша сборка с переводом. Я всю ее просто развернул поверх, сохранив свой wp-config.php. Когда появилась «Панель приборов» — не обратил внимания. Раньше не было. Если это не Ваш перевод, то удивительно, что он не обновился.
    Кстати, новая тема для админки у меня почему-то не срабатывает. В плагинах активируется, но ничего не происходит. Ошибок тоже не выдает. Что может быть?

  75. Lecactus 5 апреля 2008 в 10:43

    вы адресом сайта ошиблись. Панель приборов — это не в моем переводе, а в переводе “официального wp”

    Интересно получается: я скачал WP сначала с «официального wp»? обновился, потом появилась Ваша; скачал ее и развернул поверх предыдущей. О Панели прибоов сообщил — ибо стало напрягать. Что же в результате произошло?
    Кстати, новая темя для админки не работает у меня почему-то. В плагинах применяется, но ничего не происходит. Ошибок тоже не выдает. Что может быть?

    удалите папку wp-content/languages там и находится тот перевод то вам не нравится. мой находится в wp-includes/languages . ВП сначала ищет в wp-content , а если не находит там то в wp-includes. Т.е. то что вы ставили первым имеет выше приоритет.
    если не активируется плагин то это может означать в основном то что не хватает ему памяти для операции.

  76. Consi 5 апреля 2008 в 23:54

    Привет) Отличная версия. только у меня почему-то не захотел работать wp-polls когда пытаюсь создать опрос получается такая ошибка

    {Ошибка при добавлении опроса ‘Узнать работает ли он или нет?’.

    Ошибка при добавлении ответа опроса ‘Да конечно!’.

    Ошибка при добавлении ответа опроса ‘Нет конечно!’.}
    Не знаете из-за чего такое может быть?

  77. Lecactus 6 апреля 2008 в 0:17

    Ошибка при добавлении ответа опроса ‘Нет конечно!’.}
    Не знаете из-за чего такое может быть?

    обновите плагин до новой бета версии
    только на русский я его еще не переводил

  78. Consi 6 апреля 2008 в 0:35

    Всё отлично) Спасибо, а насчет русского… Модуль не такой уж и сложный, чтобы запутаться без великого и могучего

  79. Consi 6 апреля 2008 в 22:11

    А можно еще один вопрос… Поставил вп-онлайн новую бетку, всё работает нормально только одна проблема, когда создаешь страницу статистики, то где пишет какой-конкретно юзер или бот онлайн, вылазять какие-то вопросы, не знаете, что это может быть?

  80. Lecactus 6 апреля 2008 в 23:01

    А можно еще один вопрос… Поставил вп-онлайн новую бетку, всё работает нормально только одна проблема, когда создаешь страницу статистики, то где пишет какой-конкретно юзер или бот онлайн, вылазять какие-то вопросы, не знаете, что это может быть?

    оффтопик. обсуждайте на форумах. имхо проблема в кодировке таблиц

  81. Alexandr 7 апреля 2008 в 3:51

    удалите папку wp-content/languages там и находится тот перевод то вам не нравится.

    Спасибо. Помогло.

    если не активируется плагин то это может означать в основном то что не хватает ему памяти для операции.

    Плагин активируется, но не работает и ошибок никаких не валится. Деактивируется тоже без проблем.
    Настройки для PHP:
    max_execution_time = 30 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
    memory_limit = 128M ; Maximum amount of memory a script may consume (128MB)

    Сомневаюсь я, чтоб ему не хватало ресурсов.

  82. Lecactus 7 апреля 2008 в 9:52

    2Alexandr — а плагин вообще официально совместим с 2.5?

  83. vi 8 апреля 2008 в 0:09

    При заходе на /wp-admin/install.php

    Warning: Cannot modify header information — headers already sent by (output started at /*******/wp-config.php:1) in /*******/wp-admin/install.php on line 17

  84. Lecactus 8 апреля 2008 в 10:19

    При заходе на /wp-admin/install.php

    Warning: Cannot modify header information — headers already sent by (output started at /*******/wp-config.php:1) in /*******/wp-admin/install.php on line 17

    HANDS.DLL нужно использовать правильно
    — если кратко — используйте нормальные текстовые редакторы. тема закрыта

  85. Stanislav 8 апреля 2008 в 17:27

    Если пользоваться визуальным редактором, то при наведении на последнюю кнопку высвечивается «Показать/скрыть кухню». Может все-таки сделать что было «Показать /скрыть меню» — так все-таки приличней будет

  86. Lecactus 8 апреля 2008 в 17:38

    Если пользоваться визуальным редактором, то при наведении на последнюю кнопку высвечивается «Показать/скрыть кухню». Может все-таки сделать что было «Показать /скрыть меню» — так все-таки приличней будет

    действительно, только сейчас заметил. просто фраза заковыристая, про нее даже в википедии пишут исправление внесу вечером.

  87. Иван 8 апреля 2008 в 22:11

    Скачал, поставил wp2.5
    почему-то вся админка а английском и все даты (не смотря на включенный russian date) на английском. Как включить русский ?

  88. Lecactus 8 апреля 2008 в 22:36

    Скачал, поставил wp2.5
    почему-то вся админка а английском и все даты (не смотря на включенный russian date) на английском. Как включить русский ?

    http://lecactus.ru/rules/ в ПОИСК

  89. Alexandr 9 апреля 2008 в 1:48

    2Alexandr — а плагин вообще официально совместим с 2.5?

    Конечно. Это новая тема для админки из твоей сборки. Я ее и с офф-сайта самостоятельно качал :-)

  90. Oziris 9 апреля 2008 в 2:24

    При попытке загрузить файл, появляется такая штука:

    [quote]Не могу создать директорию /www/ИМЯ САЙТА/www/htdocs/wp-content/2008/04. Проверьте, доступна ли родительская директория для записи.

    Понятно, что путь какой-то странный. Где исправить этот глюк?

    Спасибо!

  91. Lecactus 9 апреля 2008 в 9:33

    При попытке загрузить файл, появляется такая штука:

    Понятно, что путь какой-то странный. Где исправить этот глюк?

    Спасибо!

    путь абсолютно нормальный. в поиск!

  92. Lecactus 9 апреля 2008 в 9:35

    2Alexandr — а плагин вообще официально совместим с 2.5?

    Конечно. Это новая тема для админки из твоей сборки. Я ее и с офф-сайта самостоятельно качал :-)

    извините, я вас с другим перепутал :-) у вас КАКОЙ браузер? Я не проверял, но говорят в IE не работает оно. В ФФ,Сафари и Опере работает

  93. OlegT 11 апреля 2008 в 20:24

    Забавно работает плагин All in One SEO Pack. Плагин тоже, кстати уже модифицированый под WP 2.5.

    Делаю главную страницу проекта постоянной, в шаблон накидываю код с выводом записей из разных рубрик. Все остальное нормально All in One SEO Pack обрабатывает, а титл главной страницы упорно делает из титла одной из рубрик. В шаблоне применяю код практически идентичный для вывода записей разных рубрик.

    И так, и эдак мучал его, чтобы добиться, по какому признаку рубрика эта понравилась, никак не хочет отдавать :)

    Весь код перерыл, рубрику снес, стало нормально. Создал заново, опять схватил ее и стал у главной страницы в титл писать. Уж и не знаю как лечить это безобразие, и кто тут виноват All in One SEO Pack или WP 2.5.

  94. Soul_Reaver 15 апреля 2008 в 8:42

    кактус а сделай перевод свежей WP-Polls для 2.5 ;(

  95. Lecactus 15 апреля 2008 в 8:55

    кактус а сделай перевод свежей WP-Polls для 2.5 ;(

    в процессе уже. не все сразу :-)

  96. Lecactus 15 апреля 2008 в 17:29

    кактус а сделай перевод свежей WP-Polls для 2.5 ;(

    готово. смотреть знаешь где :)

  97. Soul_Reaver 16 апреля 2008 в 11:31

    Спасибо ^_^

  98. Слава 20 апреля 2008 в 1:38

    Спасибо большое за перевод.. Поставил всё с нуля, русский отображается правильно.

    Вот только когда пишу пост и WP его в черновики автосохраняет, этот текст — не верной кодировки

    вот скрин http://onemen.ru/untitled-1.gif

  99. Lecactus 20 апреля 2008 в 1:59

    Вот только когда пишу пост и WP его в черновики автосохраняет, этот текст — не верной кодировки

    http://lecactus.ru/wordpress/moj-faq-po-wordpress/

  100. Слава 20 апреля 2008 в 4:38

    Вот только когда пишу пост и WP его в черновики автосохраняет, этот текст — не верной кодировки

    http://lecactus.ru/wordpress/moj-faq-po-wordpress/

    А может быть дело не в этом? просто если пост редактировать, то текст выводится на русском. Про автосохранение и постоянную ссылку.

  101. Слава 20 апреля 2008 в 5:58

    Хочу уточнить..

    если новый пост писать, то глюк как на скрине.. http://onemen.ru/untitled-1.gif

    а если редактировать черновик или старый, то всё в порядке..

  102. Lecactus 20 апреля 2008 в 10:37

    Хочу уточнить..

    если новый пост писать, то глюк как на скрине.. http://onemen.ru/untitled-1.gif

    а если редактировать черновик или старый, то всё в порядке..

    вы сначала пропишите строчки, а дальше видно будет. других причин просто не вижу. кстати у вас база 100% в правильной кодировке? utf8_general_ci должно быть задано во всей базе и всех таблицах

  103. Ned 21 апреля 2008 в 14:28

    Установил к себе на http://www.goodlancer.com . Не работает стандартный аплоад. Пишет «Вы уверены, что хотите сделать это? Пожалуйста, попробуйте ещё раз». Хоть тресни. Никто не сталкивался? Проверял в SeaMonkey, Safary, IE 8, везде результат один и тот же.

  104. Lecactus 21 апреля 2008 в 14:33

    Не работает стандартный аплоад. Пишет «Вы уверены, что хотите сделать это? Пожалуйста, попробуйте ещё раз». Хоть тресни. Никто не сталкивался? Проверял в SeaMonkey, Safary, IE 8, везде результат один и тот же.

    1 попробуйте в ФФ
    2 поставьте патч
    3 приложите лучше скриншот как это выглядит

  105. Ned 21 апреля 2008 в 15:27

    патч установлен. В FF тоже самое. Нажимаю на «добавить картинку» (или любое другое медиа) и сразу — ошибка. Flexible upload выключил на всякий случай.

    [IMG]http://i004.radikal.ru/0804/b7/e92435c40c7d.png[/IMG]

  106. Lecactus 21 апреля 2008 в 15:38

    патч установлен. В FF тоже самое. Нажимаю на «добавить картинку» (или любое другое медиа) и сразу — ошибка. Flexible upload выключил на всякий случай.

    [IMG]http://i004.radikal.ru/0804/b7/e92435c40c7d.png[/IMG]

    странно эта фраза вообще из раздела комментариев (посмотрел в файле перевода куда ведет текст). впервые такое вижу

  107. Ned 21 апреля 2008 в 15:39

    Да, может ещё принципиально — я обновлялся таким образом — скопировал файлы Вашей сборки поверх существующего сайта, потом обновил базу. Может надо было ещё какие действия произвести?

  108. Lecactus 21 апреля 2008 в 15:41

    Да, может ещё принципиально — я обновлялся таким образом — скопировал файлы Вашей сборки поверх существующего сайта, потом обновил базу. Может надо было ещё какие действия произвести?

    нет обычно ничего не требуется более. пробовали отключать ВСЕ плагины?

  109. Ned 21 апреля 2008 в 16:00

    Отключил всё. Спасибо за совет — не решался. У меня стоит ещё vbulletin и плагин для интеграции с ним. Вот из-за него и была ошибка. Жёстко — это, наверно, единственный плагин, который мне отключать никак нельзя.

  110. Ned 21 апреля 2008 в 16:11

    Очень большое спасибо! Обновил плагин, всё прошло. Включил все остальные плагины. Работает без ошибок.

  111. Слава 21 апреля 2008 в 21:32

    Хочу уточнить..

    если новый пост писать, то глюк как на скрине.. http://onemen.ru/untitled-1.gif

    а если редактировать черновик или старый, то всё в порядке..

    вы сначала пропишите строчки, а дальше видно будет. других причин просто не вижу. кстати у вас база 100% в правильной кодировке? utf8_general_ci должно быть задано во всей базе и всех таблицах

    Все строки перепробовал..
    затем проверил, кодировка utf8_general_ci — везде… замкнутый круг

  112. Lecactus 22 апреля 2008 в 9:42

    обовал..
    затем проверил, кодировка utf8_general_ci — везде… замкнутый круг

    трясите хостера. это не проблема вордпресса, а кривых настроек кодировок на сервере

  113. Alexander 23 апреля 2008 в 10:34

    когда пишу пост и WP его в черновики автосохраняет, этот текст - не верной кодировки

    вот скрин http://onemen.ru/untitled-1.gif

    Та же фигня, но только, если пытаюсь «Permalink» линк отредактировать. Т.е. ту часть пути, что на упомянутом скрине подсвечено желтым («ava»). Жму на Edit и получаю такое же. Выхожу со страницы и захожу по-новой — все ок. «Обновить страницу» не помогает.

    Кстати, может имеет смысл поставить какой-нибудь плугин, чтобы комментарии листал, а на вываливал уже вторую сотню на одной странице? Грузится долго.

  114. Lecactus 23 апреля 2008 в 12:55

    Жму на Edit и получаю такое же. Выхожу со страницы и захожу по-новой — все ок. «Обновить страницу» не помогает.

    Кстати, может имеет смысл поставить какой-нибудь плугин, чтобы комментарии листал, а на вываливал уже вторую сотню на одной странице? Грузится долго.

    смотрите выше — трясите хостера за яйца чтобы кодировки нормально настраивал
    по поводу листать комменты, возможно скоро поставлю кое что для сворачивания комментариев, но не постраничное (раздражает)

  115. Lecactus 23 апреля 2008 в 16:27

    вот еще почитайте по поводу кривых кодировок (первая часть поста)

  116. Yoshi 29 апреля 2008 в 0:58

    Ставлю твою сборку с самого начала кракозябры лезут. Переключаю в ФФ кодировку на утф8 все отлично, иду на следующую страницу там такая же беда с кодировкой. У хостера поставил утф8, не помогает. Чо делать то?

  117. Lecactus 29 апреля 2008 в 8:14

    Ставлю твою сборку с самого начала кракозябры лезут. Переключаю в ФФ кодировку на утф8 все отлично, иду на следующую страницу там такая же беда с кодировкой. У хостера поставил утф8, не помогает. Чо делать то?

    читайте выше комментарии — там ссылка на FAQ

  118. Phantom 11 мая 2008 в 5:26

    Большое вам спасибо за русифицированную версию! Она всегда встаёт ладненько, красиво и без проблем. А «родная» английская — всегда с «косяками».
    Спасибо!

  119. oldvovk 29 мая 2008 в 5:35

    Нужен совет.
    Ощущение, что кеширование в wp251 не работает.
    В папке кеш ничего не добавляется и тд и тп, хотя и
    поизгалялся в конфиге с разными —
    define(‘WP_CACHE’, true);
    define(‘ENABLE_CACHE’, »);

    Учитывая, что не силен в коде, просто заменил cash.php
    на файл из версии 232. Все вродеб запыхтело. Отрицательного
    не вижу, но —

    хотелось бы услышать мнение специалистов?

  120. Lecactus 29 мая 2008 в 7:51

    Ощущение, что кеширование в wp251 не работает.

    я вчера уже отвечал на этот вопрос в другом посте
    http://lecactus.ru/2008/04/26/2089/#comment-16002

  121. oldvovk 29 мая 2008 в 19:53

    Понятно. Просто не хотелось подключать еще плагины,
    тем более, что не очень в них уверен, с их нарастанием
    объемов кеша.

    Не знаю, в общем замена работает, запросов показывает
    уменьшение на 15-18 , % на 15-20 показывает ускорение
    генерации.

    Оставлю, как сделал. По идее не должно ни на что повлиять
    — те сломать

Трэкбеки и пингбеки

  1. Goodluck » Wordpress 2.5
  2. do_блог » Blog Archive » wordpress 2.5
  3. Переходим с WordPress 2.3.3 на 2.5? - CrazyLog.co.ua
  4. WordPress Россия » Вышел WordPress 2.5
  5. Abramkin.info | WordPress 2.5
  6. Небольшой перерыв и отдых | Блог Daster, SEO, бизнес, проекты, личное
  7. WordPress 2.5 - обновляться или нет? - Кимочи.ру
  8. Abramkin.info | WordPress 2.5
  9.   Вышел WordPress 2.5 » ДиаБлог.ру
  10. SKART home page » Блог Архив » UPDATE [31.03.08]
  11. 10 вещей, которые вам стоит знать о WordPress 2.5 | Блог о Wordpress от Тараса
  12. NURLAN.info » Архив блога » Обновление Wordpress